DSM EU | Infrastructure servers maintenance

Scheduled for Sep 2, 22:00 UTC  -  Sep 3, 02:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 27, 2026 - 15:56 UTC

Scheduled

Infrastructure server maintenance in our EU region is scheduled for September 2, 2026, from 10:00 PM UTC to September 3, 2026, at 02:00 AM UTC. There would be minimal or no impact on operations. If you experience any issues, please contact Fortanix Support.
Posted Aug 27, 2026 - 15:55 UTC
This scheduled maintenance affects: DSM SaaS (EU) (Service availability).